File:  [gforth] / gforth / gforth.spec
Revision 1.4: download - view: text, annotated - select for diffs
Sun Jan 9 20:04:15 2011 UTC (13 years, 3 months ago) by pazsan
Branches: MAIN
CVS tags: HEAD
Added ppoll to socket.fs, made string.fs re-requireable even under different path (string.fs is now included inside the kernel, and the require interface works only for the image generation

    1: #
    2: # spec file for package gforth (Version 0.7.0)
    3: #
    4: # Copyright (c) 2009 SUSE LINUX Products GmbH, Nuernberg, Germany.
    5: #
    6: # All modifications and additions to the file contributed by third parties
    7: # remain the property of their copyright owners, unless otherwise agreed
    8: # upon. The license for this file, and modifications and additions to the
    9: # file, is the same license as for the pristine package itself (unless the
   10: # license for the pristine package is not an Open Source License, in which
   11: # case the license is the MIT License). An "Open Source License" is a
   12: # license that conforms to the Open Source Definition (Version 1.9)
   13: # published by the Open Source Initiative.
   14: 
   15: # Please submit bugfixes or comments via http://bugs.opensuse.org/
   16: #
   17: 
   18: Name:           gforth
   19: %if 0%{?suse_version}
   20: BuildRequires:  emacs-nox libffi-devel
   21: PreReq:         %{install_info_prereq}
   22: %endif
   23: %if 0%{?rhel_version} || 0%{?centos_version}
   24: BuildRequires:  emacs-nox libtool-ltdl-devel
   25: Requires:       libtool-libs libtool-ltdl libtool-ltdl-devel
   26: %endif
   27: %if 0%{?fedora}
   28: BuildRequires:  emacs-nox libtool-ltdl-devel libffi-devel
   29: Requires:       libffi libtool-libs libtool-ltdl libtool-ltdl-devel libffi-devel
   30: %endif
   31: Url:            http://www.complang.tuwien.ac.at/forth/gforth/
   32: License:        GNU Free Documentation License, Version 1.2 (GFDL 1.2); GPL v2 or later; GPL v3 or later
   33: Group:          Development/Languages/Other
   34: AutoReqProv:    on
   35: Version:        0.7.9
   36: Release:        62.1
   37: Summary:        GNU Forth
   38: Source:         gforth-%{version}.tar.gz
   39: BuildRoot:      %{_tmppath}/%{name}-%{version}-build
   40: 
   41: %description
   42: Gforth is a fast and portable implementation of the ANS Forth language.
   43: 
   44: 
   45: 
   46: Authors:
   47: --------
   48:     Anton Ertl <anton@mips.complang.tuwien.ac.at>
   49:     Bernd Paysan <bernd.paysan@gmx.de>
   50:     Jens Wilke <wilke@jwdt.com>
   51: 
   52: %prep
   53: %setup -q
   54: 
   55: %build
   56: # Fixup timestamps. Can't rebuild them without working gforth
   57: touch engine/prim.i engine/prim_lab.i
   58: %{?suse_update_config}
   59: autoreconf -fi
   60: CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE" \
   61: ./configure --prefix=/usr --mandir=%{_mandir} --infodir=%{_infodir} \
   62:             --build=%{_target_cpu}-suse-linux
   63: make
   64: emacs --batch --no-site-file -f batch-byte-compile gforth.el
   65: echo > gforth-autoloads.el
   66: emacs --batch -l autoload --eval "(setq generated-autoload-file \"$PWD/gforth-autoloads.el\")" -f batch-update-autoloads .
   67: {
   68:   printf ';;; suse-start-gforth.el
   69: ;;
   70: ;;; Code:\n
   71: (add-to-list '\''auto-mode-alist '\''("\\\\.fs\\\\'\''" . forth-mode))\n\n'
   72:   sed -n '/^;;; Generated/,/^;;;\*\*\*/p' gforth-autoloads.el
   73:   printf '\n;;; suse-start-gforth.el ends here\n'
   74: } > suse-start-gforth.el
   75: make install.TAGS
   76: rm gforth.fi
   77: 
   78: %check
   79: make check
   80: 
   81: %install
   82: make install DESTDIR=$RPM_BUILD_ROOT prefix=/usr mandir=%{_mandir} infodir=%{_infodir}
   83: install -d $RPM_BUILD_ROOT/usr/share/emacs/site-lisp
   84: install -m 644 gforth.el gforth.elc suse-start-gforth.el $RPM_BUILD_ROOT/usr/share/emacs/site-lisp
   85: 
   86: %clean
   87: rm -rf $RPM_BUILD_ROOT
   88: 
   89: %post
   90: %install_info --info-dir=%{_infodir} %{_infodir}/gforth.info.gz
   91: 
   92: %postun
   93: %install_info_delete --info-dir=%{_infodir} %{_infodir}/gforth.info.gz
   94: 
   95: %files
   96: %defattr(-,root,root)
   97: %doc README BUGS NEWS
   98: /usr/bin/*
   99: /usr/include/gforth
  100: /usr/lib/gforth
  101: /usr/share/emacs/site-lisp/*.el*
  102: /usr/share/gforth
  103: %if 0%{?suse_version}
  104: %dir /usr/share/gforth/site-forth
  105: %config /usr/share/gforth/site-forth/siteinit.fs
  106: %else
  107: /usr/share/info/dir
  108: %endif
  109: %doc %{_infodir}/*.gz
  110: %doc %{_mandir}/man?/*
  111: 
  112: %changelog
  113: * Thu Dec 23 2010 bernd.paysan@gmx.de
  114: - Started buildservice project
  115: * Thu Nov 06 2008 schwab@suse.de
  116: - Update to gforth 0.7.0.
  117:   Requirements:
  118:   At run-time requires libtool and gcc (for the libcc C interface) and
  119:   gdb (for the disassembler (SEE)) on some platforms.
  120:   Installation:
  121:   support for DESTDIR, POST_INSTALL, INSTALL_SCRIPT
  122:   automatic performance tuning on building (--enable-force-reg unnecessary)
  123:   report performance and functionality problems at end of "make"
  124:   autogen.sh now exists
  125:   License:
  126:   Changed to GPLv3
  127:   Bug fixes
  128:   Now works with address-space randomization.
  129:   The single-step debugger works again in some engines.
  130:   Many others.
  131:   Ports:
  132:   AMD64, ARM, IA-64 (Itanium): better performance
  133:   PPC, PPC64: disassembler and assembler
  134:   Gforth EC: R8C, 4stack, misc, 8086 work
  135:   MacOS X: better support
  136:   Invocation:
  137:   New flags --ignore-async-signals, --vm-commit (default overcommit)
  138:               --print-sequences
  139:   Forth 200x:
  140:   X:extension-query: produce true for all implemented extensions
  141:   X:required REQUIRED etc. (not new)
  142:   X:defined: [DEFINED] and [UNDEFINED]
  143:   X:parse-name: PARSE-NAME (new name)
  144:   X:deferred: deferred words (new: DEFER@ DEFER! ACTION-OF)
  145:   X:structures: +FIELD FIELD: FFIELD: CFIELD: etc.
  146:   X:ekeys: new: EKEY>FKEY K-SHIFT-MASK K-CTRL-MASK K-ALT-MASK K-F1...K-F12
  147:   X:fp-stack (not new)
  148:   X:number-prefixes (partially new, see below)
  149:   Number prefixes:
  150:   0x is a hex prefix: 0xff and 0XfF now produces (decimal) 255
  151:   [#] is a decimal prefix: #10 now produces (decimal) 10
  152:   Signs after the number prefix are now accepted, e.g, #-50.
  153:   ' now only handles a single (x)char: 'ab is no longer accepted,
  154:   'a' now produces (decimal) 97
  155:   Unicode support (currently supports only uniform encoding):
  156:   added xchars words for dealing with variable-width multi-byte characters
  157:   provide 8bit (ISO Latin 1) and UTF-8 support for xchars
  158:   New words:
  159:   \C C-FUNCTION C-LIBRARY END-C-LIBRARY C-LIBRARY-NAME (libcc C interface)
  160:   LIB-ERROR (complements OPEN-LIB)
  161:   OUTFILE-EXECUTE INFILE-EXECUTE BASE-EXECUTE (limited change of global state)
  162:   16-bit and 32-bit memory acces: UW@ UL@ SW@ SL@ W! L! W@ L@ /W /L
  163:   NEXT-ARG SHIFT-ARGS (OS command-line argument processing)
  164:   NOTHROW (for backtrace control)
  165:   FTRUNC FMOD (undocumented)
  166:   SEE-CODE SEE-CODE-RANGE (show generated dynamic native code)
  167:   Improvements/changes of existing words:
  168:   S\", .\" now support \l, \m, \z, and limits hex and octal character specs.
  169:   OPEN-FILE with W/O no longer creates or truncates files (no compat. file)
  170:   OPEN-LIB now understands ~ at the start, like OPEN-FILE.
  171:   TRY...ENDTRY changed significantly, compatibility files available (see docs).
  172:   The disassembler (DISCODE) can now use gdb to disassemble code
  173:   Uninitialized defered words now give a warning when executed
  174:   Division is floored (disable with "configure --enable-force-cdiv")
  175:   Gforth (not gforth-fast) reports division by zero and overflow on division
  176:   on all platforms.
  177:   Newly documented words:
  178:   S>NUMBER? S>UNUMBER?
  179:   EKEY keypress names: K-LEFT  K-RIGHT K-UP K-DOWN K-HOME K-END K-PRIOR
  180:   K-NEXT K-INSERT K-DELETE
  181:   CLEARSTACKS
  182:   FORM
  183:   Environment variable GFORTHSYSTEMPREFIX (used by word SYSTEM and friends)
  184:   C interface:
  185:   exported symbols now start with "gforth_" (for referencing them from C code)
  186:   libcc C function call interface (requires libtool and gcc at run-time)
  187:   alternative: undocumented libffi-based interface
  188:   Libraries:
  189:   depth-changes.fs: report stack depth changes during interpretation
  190:   ans-report.fs now reports CfV extensions
  191:   fsl-util.4th: FSL support files (undocumented)
  192:   regexp.fs for regular expressions (undocumented)
  193:   complex.fs for complex numbers (undocumented)
  194:   fft.fs for Fast Fourier Transform (undocumented)
  195:   wf.fs, a Wiki implementation (undocumented)
  196:   httpd.fs, a web server (undocumented)
  197:   status.fs, show interpreter status in separate xterm (undocumented)
  198:   profile.fs for profiling (undocumented, incomplete)
  199:   endtry-iferror.fs, recover-endtry.fs to ease the TRY change transition
  200:   test/tester.fs: Now works with FP numbers (undocumented)
  201:   test/ttester.fs: Version of tester.fs with improved interface (T{...}T).
  202:   compat library:
  203:   compat/execute-parsing.fs
  204:   Speed improvements:
  205:   automatic performance tuning on building
  206:   static stack caching (good speedup on PPC)
  207:   mixed-precision division is now faster
  208:   support for int128 types on AMD64
  209:   workarounds for gcc performance bugs (in particular, PR 15242)
  210:   branch target alignment (good speedup on Alpha).
  211: * Wed Jul 09 2008 schwab@suse.de
  212: - Fix last change.
  213: * Sat Jul 05 2008 schwab@suse.de
  214: - Fix use of undocumented autoconf variable.
  215: * Thu Oct 11 2007 schwab@suse.de
  216: - Remove obsolete options.
  217: * Wed Jan 25 2006 mls@suse.de
  218: - converted neededforbuild to BuildRequires
  219: * Thu Jan 19 2006 schwab@suse.de
  220: - Don't strip binaries.
  221: * Tue Dec 20 2005 dmueller@suse.de
  222: - fix file list
  223: * Wed Jan 21 2004 schwab@suse.de
  224: - Workaround gcc 3.3 bug.
  225: * Fri Jan 09 2004 schwab@suse.de
  226: - Update to gforth 0.6.2.
  227: * Tue Oct 28 2003 schwab@suse.de
  228: - Fix quoting in configure script.
  229: * Wed Jul 02 2003 schwab@suse.de
  230: - Fix references to build root.
  231: * Tue May 13 2003 schwab@suse.de
  232: - Fix filelist.
  233: * Thu Apr 24 2003 ro@suse.de
  234: - fix install_info --delete call and move from preun to postun
  235: * Wed Apr 23 2003 schwab@suse.de
  236: - Enable use of long long on ppc.
  237: - Fix and compile gforth.el.
  238: - Add suse-start-gforth.el.
  239: - Include all gforth variants.
  240: * Tue Apr 22 2003 schwab@suse.de
  241: - Use BuildRoot.
  242: * Mon Apr 07 2003 schwab@suse.de
  243: - Only delete info entries when removing last version.
  244: * Thu Mar 27 2003 schwab@suse.de
  245: - Update to gforth 0.6.1.
  246: * Thu Feb 06 2003 schwab@suse.de
  247: - Use %%install_info.
  248: * Tue Sep 17 2002 ro@suse.de
  249: - removed bogus self-provides
  250: * Thu Apr 18 2002 schwab@suse.de
  251: - Fix alpha port for gcc3.
  252: * Thu Apr 18 2002 schwab@suse.de
  253: - Fix i386 port for gcc3.
  254: * Mon Feb 25 2002 schwab@suse.de
  255: - Fix permissions.
  256: * Tue May 08 2001 mfabian@suse.de
  257: - bzip2 sources
  258: * Sun Apr 15 2001 schwab@suse.de
  259: - Fix pointer <-> int clash.
  260: * Fri Oct 06 2000 schwab@suse.de
  261: - Update to version 0.5.0.
  262: * Thu Aug 17 2000 schwab@suse.de
  263: - Fix ia64 configuration.
  264: * Thu Aug 17 2000 schwab@suse.de
  265: - Basic support for ia64.
  266: * Tue Jan 18 2000 schwab@suse.de
  267: - /usr/{info,man} -> /usr/share/{info,man}
  268: * Mon Sep 13 1999 bs@suse.de
  269: - ran old prepare_spec on spec file to switch to new prepare_spec.
  270: * Mon Aug 30 1999 schwab@suse.de
  271: - specfile cleanup
  272: - fix prims2x.fs:read-whole-file for make check
  273: * Fri May 21 1999 ro@suse.de
  274: - update to 0.4.0
  275: * Sat Jun 07 1997 florian@suse.de
  276: - first version of GNU forth 0.3 for S.u.S.E.

FreeBSD-CVSweb <freebsd-cvsweb@FreeBSD.org>