File:  [gforth] / gforth / INSTALL
Revision 1.5: download - view: text, annotated - select for diffs
Sat Jan 21 17:26:40 1995 UTC (24 years, 6 months ago) by anton
Branches: MAIN
CVS tags: HEAD
updated INSTALL and README
now demand-paged executables are made everywhere
mips.h now supports Irix

Preliminary version

You need gcc version 2.0 or later to compile gforth.
First, type

configure

configure has the following useful parameters:
-direct-threaded: setup for a direct threaded interpreter; this is faster
   on many machines, but needs special support. Unsupported machines will
   ingore this switch. On some CISC machines, direct threading isn't an
   advantage over indirect threading.

-without-debug: omits the -g switch and creates smaller images on machines
   where "strip" has problems with gcc style debugging informations.

--help: tells you about other parameters.

Now type

make

If your make has trouble with the Makefile, "make gforth" might work.

If your installed gcc isn't called "gcc" (eg. called "gcc-2.6.1"), type

make CC=<whatever you call your gcc>

instead.

FreeBSD-CVSweb <freebsd-cvsweb@FreeBSD.org>